SSL Certificate
St. Francis Area Schools
A PreK-12 public school district serving the communities of Athens Township, Andover, Bethel, East Bethel, Linwood Township, Nowthen, Oak Grove, St. Francis and Stanford Township

Infinite Campus Portal
Hardware/Software Requirements

This information covers the minimum supported platform requirements for computers, internet browsers and mobile devices.

Upcoming Changes to Supported Platforms

Notable upcoming changes to platform support are summarized in the following table:

Safari 5.x

Safari 5.x will no longer be supported.

June 2015

Internet Explorer 7

IE 7 will no longer be supported.

June 2015

Internet Explorer 8

IE 8 will no longer be supported.

June 2015

Supported Browsers

Campus is supported on all Windows or Macintosh computers running any of the supported browsers listed in the table below.

Windows Internet Explorer

IE 7.x, IE 8.x, IE 9.x, IE10.x

IE11 is not officially supported at this time however, we are currently working on updating Campus to work properly within the browser.

If you encounter issues when using Campus within IE11, please have your Authorized Support Contact submit a support case.

Meetings Management functionality requires Internet Explorer 8+.

Campus Instruction requires Internet Explorer 10.

Windows Chrome

Campus supports the current and most recent previous version of Chrome.

Windows Firefox

Campus supports the current and most recent previous version of Firefox.

Mac Safari

Safari 5, Safari 6, Safari 7

Safari 8 is not officially supported at this time however, we are currently working on updating Campus to work properly within the browser.

If you encounter issues when using Campus within Safari 8, please have your Authorized Support Contact submit a support case.

Mac Chrome

Campus supports the current and most recent previous version of Chrome.

Mac Firefox

Campus supports the current and most recent previous version of Firefox.

iOS Safari

The Campus web application is currently not supported for use on iOS devices.

Android The Campus web application is currently not supported for use on Android devices.

Related Software Minimums

The following table describes the Campus-supported minimum versions of third-party software needed to properly use Campus.

Adobe Flash

Adobe Flash Player 10.X or higher is required for use of the Data Analysis tool on all Campus-supported platforms.

Adobe Reader

Infinite Campus does not support the use of Adobe Reader on platforms that are not supported by the third-party product vendors. See the following articles for more information:

Internet Explorer—Properly Saving FDF Forms

Firefox—Enabling Adobe Acrobat to Open PDF/FDF Files

Safari—Properly Opening FDF/PDF Files

Chrome—Disabling the Chrome PDF Viewer

Note to Macintosh Users:

FDFs do not work for users on OS X 10.6+ using Safari 5.1+ unless Adobe Reader is updated to 10.1.3 or higher.

Firefox use is not supported. Please use Preview.

Camino use is not supported.

FDF files are not supported in Chrome for Mac. Please open these files within Adobe Reader.

Java Version

Standard Version 6 Update 12


Mobile and Tablet Browsers Supported Platforms

The following table defines current support for the Mobile Portal app. Note: as of the 2014-15 school year, Campus will only support iOS 6.0+ and Android 2.2+.

Apple Mobile Devices
(iPod Touch, iPhone)

iOS 6.0+

Apple Tablet Devices (iPad, iPad Mini)

iOS 6.0+

Android Mobile Devices (Phones)

Android 2.2+

Android Tablet Devices

Android 2.2+

First generation of iPhone and iPod Touch is not supported. BlackBerry and Windows-based mobile phones are not supported.
For Android users, Campus does not support screen sizes deemed too small for the Google Play store.

Questions?

Email campus.help@isd15.org

powered by finalsite